EC-CUBE2.17.1をインストールしてみると

EC-CUBE2.17というバージョンは5年ほど前に最後の2系2.13.5のバージョンを最近のレンタルサーバでも使えるようにPHP7対応にしたバージョン。

最近2.17系がPHP7.4に対応し2.17.1としてリリースされています。

実際2.17系をインストールしてみるとフロントや管理画面は従来の2.13.5とほぼ同じです。

DEMO
http://www.eccube-plus.com/___eccube/eccube2171/

2.17系のリリースサイトでは2.17から2.17.1によって下記が修正されたとのことでこのバージョンだとPHPは5.4から7.4の間で動作することになりますのでもし2系をまだ使いたい方は比較的長く使うことは可能ですね。

  • HTTP クッキーをより安全にする SameSite 属性に対応
  • PHP7.4対応
  • 2.13系プラグインとの互換性向上(2.13系プラグインの動作を保証するものではありません)

引用:https://github.com/EC-CUBE/ec-cube2/releases

EC-CUBE2.17.1の管理画面

実際にPHP7.2、データベースはMariaDBのMySQL10.4にインストールし管理画面のキャプチャになります。

管理画面を触った感じだとおそらく体感としても処理は2.13より早いと思います。

EC-CUBEW2.4や2.11、2.12、2.13から2.17.1へのバージョンアップ

EC-CUBE2.17.1へのバージョンアップは当社で代行作業しています。
2系のすべてのバージョンの経験があるので細かい部分のアップデート含めお見積もりいたします。

お見積もり希望の方はこちらのフォームからご連絡くださいませ。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA