PHP7対応のEC-CUBE2.13.5は結局どうなった? 実はEC-CUBE2.17としてβ版すでにあります

ここ1・2年新たにレンタルサーバを契約すると、あるいは数年前に契約したサーバも突然告知がきて 「PHPのバージョン切り替えを行います」だったり、古いPHPバージョンは徐々に使えなくなっていくケースが増えてきています。

最近のサーバはかなりのペースでPHP7がメインのバージョンになりつつありま。

数年前に更新が終わったEC-CUBE2系の最終バージョンEC-CUBE2.13.5はPHP5.2からギリギリPHP5.4で動作するように作られているようなので、それ以外のPHPでインストールしようとするとエラーがかなり出てくると思います。PHP7にEC-CUBE2.13.5は基本的にインストールはできないものと考えてOKなのですが、

まだ2系のEC-CUBEでECショップを構築したいケースもあると思います。そこで1年ほど前からPHP7対応のEC-CUBE2.13.5を作ろうということで開発されていたのですが、

現在どうなったのか・・・

実は去年の9月にβ版がGithubで公開されそれから数ヶ月立っていますが、まだ正式リリースではないものの存在するのです。

https://github.com/EC-CUBE/eccube-2_13/releases/tag/eccube-2.17.0-alpha

開発者様やEC-CUBEに詳しい方は一度ご自身でインストールしてみるものありかと思いますが、実際使うとなるとプラグインやモジュールの動作を念入りにしてから使う必要あると思います。

そこまでプラグインやモジュール使わないでいい場合はすでに通常通り現在の新しいサーバでも使えるかもしれませんのでご自身の判断になりますが検討してみるのもありかと思います。

 

■プレスリリース

https://www.ec-cube.net/news/detail.php?news_id=290

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA